Field noteOct 23, 20261 min read1 source

CISA urges immediate patching of php2shell PHP flaws CVE-2026-109618 and CVE-2026-109619

In one minute

CISA has urged organizations to immediately patch two critical PHP vulnerabilities, CVE-2026-109618 and CVE-2026-109619, collectively referred to as php2shell.

What changed: CISA now urges immediate patching and has updated its alert with a SIGMA detection rule, partner resources, and reinforced mitigation guidance.

The October 21 alert was revised on October 23, 2026 to add a SIGMA detection rule, partner resources, and reinforce mitigation guidance.

CISA says the flaws allow unauthenticated remote code execution in PHP installations that serve web requests. It lists Apache with mod_php, PHP-FPM, php-cgi, FrankenPHP, and LiteSpeed among affected deployment types. The agency directs organizations to update to PHP 8.5.12, 8.4.27, 8.3.36, or 8.2.35, prioritizing internet-facing systems.

Organizations unable to update immediately, including those on unsupported PHP 8.1 or earlier, are advised to take affected PHP systems offline until patched or updated. A web application firewall may provide partial temporary protection. CISA also advises monitoring for PHP worker processes that launch shells or download tools. The alert does not establish that the vulnerabilities have been successfully exploited in the wild; CISA said it had not observed such exploitation at publication.

Evidence / sources

  1. 1cisa.gov/news-events/alerts/2026/10/21/critical-vulnerabilities-php-require-immediate-patching
All Field Notes

Next reads

Read next

Open the graph
  1. 01topicSecurityExplore the security topic hub.
  2. 02archiveField NotesOpen the latest editorial analysis.
  3. 03source ledgerSource LedgerInspect the public source evidence graph.
Who read this page?Machine requests, hidden until opened

Loading the privacy-safe route aggregate...

Open the JSON contract